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1. Registration

Existing Employee/Retiree

If you are an existing employee or retiree, check your latest paper payslip. A PIN number to register
for online payslips will be displayed at the bottom of your payslip. You should also take note of your
Personnel number on your payslip.

Click on https://epayslips.hse.ie/Account/Login.aspx or follow the links on the Tusla Website — Staff
(top right) - Online Payslips and click ‘Register’.

Note: There is an instructional video on the site which will take you step by step through the registration and
login process

Step 1

Enter your Personnel Number and PIN in the boxes provided. A PIN number to register for online
payslips is displayed at the bottom of your payslip.

Register for Online Payslips Service

To access your online payslips, you must first
register and provide us with an email address. This
can be either a work or personal email address.

Enter your personnel number and PIN below.

You will find your Personnel number and PIN on
your paper payslip.

Step 1
Personnel Number:

PIM:

P

Click Register
Step 2
You will be prompted to enter and confirm an email address. You can use either a work or personal
email address. This email address will initially be used to send you an activation link to login to the
online payslips application and for password resets thereafter.

Register for Online Payslips Service

Set Email address

An email address is required to register for this
service. You can use a work or a personal email.

Step 2

E-mail:

Confirm E-mail:

/

Click Set Email



The following message will display at the end of the screen:

Verification Mail Sent

A verification email has been sent to you.

Please check your inbox and complete the
registration process by clicking on the link in
the email.

Please note, the email may take a few minutes to
arrive - please be patient. You may now close this
window.

2. Activating your Online Payslip Account

Check the email account that you used to register. You should receive an e-mail with an activation
link to your online payslip account and a temporary password.

If you are using webmail such as Gmail or Yahoo please remember to check the Spam/Junk folders
as automated emails are often sent to these folders. Webmail account access may be blocked when
being accessed from within the HSE network.

From: ' epaysips@hse.ie Sent: Thu 09ji4/2015
Tae

L=

Subpact:  HSE Online Payshps emal verification

|T-:| complete your registration you will need to mctivate your online payslips account.

Please click on the link below:
heep=://epay=slip=.hse. ie/Nevlook/Verify.aspx 7 ID=0daseld8-a10a-4af3-Elch-al12 ff0bathdd

Tour temporacy password is: +3Nbtgyw

Please note your temporary password is case sen=itiwve.

The link above is for registration purposes only, once registered go to the onlinepayslips login page to sign in
fNewlLook/ Account/Login. aspx

Once registered, you will no longer receive paper payslips.

You will need to click on the link to activate your online payslip account.

The following screen will appear with a message advising that your account has been verified. You
can now login by clicking the ‘Login to Online Payslips Application’ link

Account Verified

Your account has been verified and you can now log
into the site.

@nline Payslips Application

Click here to Login/




Enter your Personnel No and Temporary Password which you will have received on the email
verification. Click Login

New User Login
Please log-in using the temporary password sent to

you by email.

Personnel No:

Temporary Password:

=

You will be prompted to set a password to something memorable. The password should be 8
characters long and include a special character such as !, #, etc. On initial login, your current
password is the temporary password emailed to you on registration.

Account Maintenance

Password Update

Please update your password to complete your
registration.

Passwords must be at least 8 characters long
and must contain at least one special character
e, (M"EE% N EE =@ e <> P

Current Password / Temporary Password:
MNew Password:

Confirm Mew Password:

< - B

Click here Account Maintenance

Password Update

Change Password Complete

Your password has been changed!

Toamme >

Click here



3. Logging In

To ‘Login’ enter your 8 digit Personnel number, password and email address in the boxes provided.
Click the Log In button.

Welcome to the Online Payslips Service

Login Register for Online Payslips Service

To access your online payslips, you must first register

Personnel No:
and provide us with an email address.

You will find your Personnel number and PIN on your

paper payslip.

Password:

Email Address:

User Guide Registration
Instructional Video

Forgotten your Password?

Click here

New Employee (New Hire/Rehire)

If you are a new/rehired employee, you will automatically be registered for online payslips. An
activation link to your online payslip account and a temporary password will be sent to the email
address that you provided on your HR Hire/Rehire form. Please follow steps 2 & 3 above to activate
your account and login.



4. View My Documents

4.1 View a current Payslip
On the Home page click View My Documents

Welcome to the Online Payslips Service

Please select from one of the options below:

5

Account Maintenance

Click here /

Employee Self Service

View P60 2013

Click here.
Your most recent payslip will display.

4.2 View a previous Payslip

Select the Pay Date you wish to view from the drop down. Tick the Pay Date you wish to view
line Payslips Service

Welcome 220000
Login  User Guide

View My Documents

Home

Select Year 2014 y Date TURR014
Display Postal Add N B select pi
isplay Fosta ress o A
¥ 31.03£014
4 4 1 of1 kKl & Find 5.02.2014
[131.01.2014

To print payslips click on the export icon -t{ » in grey bar above

Click on “View Document” twice to display the chosen payslip on screen.



4.3 View multiple Payslips

On the Pay Date drop down tick ‘Select All'. Click on “View Document” twice. Your first payslip will
display.

Online Payslips Service

Welcome 30016763 [ Log Out |

Home Account Maintenance

Select Year 2014

[¥]31.05.2014
[¥130.04.2014
[V aerea.2014

Display Postal Address  No

4 4 1 of1 b Pl <@

To print payslips click on the export icon  #, + in grey bar above

To view the next month’s payslip Click the Next Page arrow

View My Documents  Login ~ User Guide

A Fay Date  31.05.2014, 30.04.2014, 30.03.2¥|

L] Find | Find Next % S

To print payslips click on the export icon . + in grey bar above

4.4 Display a Postal Address

You have the option to “Display postal address”. Click Yes from the dropdown to the right and click
“View Document” The postal address will then appear on screen.

Online Payslips Service

Welcome 22000029 [ Log Out ]
Account Maintenance View My Documents Login User Guide

Select Year 2014 - Pay Date 31.03.2014 >l

Display Postal Address £ -
No
4 4 1 of Q’ Find | Find Next =, =

= click on the export icon W, - in grey bar above

Home

Click here



4.5 View Your P60
On the Home page click View My Documents

Account Maintenance \ View My Documents

View Online Payslip
.

View P60 2014
_

View P60 2013

You can view your P60 for 2013 or 2014

5. Online Payslip Account Maintenance

5.1 Change my Password

On the Home page click Account Maintenance

& Home & Account Maintenance

Click = — Change Password
1 CCOLIm dinternarce
\> hange Password

= wiew My Documents

Change Email Address
® Help Center

@& Log Cut

Follow the instructions on screen to change your password. You will be prompted to set a password.
The password should be 8 characters long and contain at least one special character such as !, #,
etc.

Password Reset

Passwords must be at least 8 characters long and must contain at least one special character i.e.
(H"ES% EF_+-=@ mFE<>P.

Current Password:
New Password:

Confirm New Password:



Click Change and the following message will appear. Click the continue button

Password Reset

Change Password Complete

Your password has been changed!

5.2 Change Email Address

Click Change Email Address on the Account Maintenance page.

& Account Maintenance

Change Password

e Change Email Addres

Click here

The following box will appear:

E-mail Address Update

Current Emall Address

Fease enter your nesw email address
Hease confirm your emad address

Current Password:

The screen will request confirmation of your email address and password. Click Save.

6. Print Your Payslip & P60
To print a payslip or P60 click on the disk Icon. Click Export to PDF to Print.

Select Year 2014 v ay Date |31.03.2014 ™ [ View Report |
Display Postal Address | Mo A
4 4 |1 of 1 [ [l ] Find | Mext *L =

To print payslips click on the export icon L, » in grey bar above Export to PDF to Print ﬂl

Your payslip should automatically open up and offer you the option to open your PDF document or
save it. If you do not have Adobe Acrobat Reader installed on your PC then you can download it for
free at http://get.adobe.com/uk/reader After you install the application you will now be able to save or
print your payslip.

With your payslip open in adobe reader click the print icon in the toolbar.
File Edit View Document Tools Window

(B € « @[
/ 9



http://get.adobe.com/uk/reader/

Click here to print

You will then be prompted to select which printer you would like to use. Select your printer and click
ok.

6.1 Exporting in Google Chrome

When saving/printing the payslip/P60 in Google Chrome the payslip will not automatically open. The
file will appear in a download bar at the bottom of your browser window.

'E] EPayslip_w1.pdf =

Click on the file and your payslip pdf will open up within google chrome.

Right click anywhere on the screen and scroll down to print. Then press print fclond

on the print menu screen that appears as seen below. \

Click print again on the next screen that appears.

Print View page info

Total: 1 sheet of paper
Rotate clockwise

/ ‘ Cancel Rotate anti-clockwise

Inspect element

Click here to print.

6.2 Download Error

Some users may experience an error message when they try to print their payslip. This is due to a
security setting within Internet Explorer that needs to be turned off in order for you to export the

payslip

Windows Internet Explorer

@ Internet Explorer cannot download .
Internet Explorer was not able to open this Internet site. The requested site is either unavailable or cannot be found. Please try again later.

To turn off the security feature you need to go to the menu bar and click Tools -> Internet Options ->
Advanced and scroll down to Security and ensure that the 'Do not save encrypted pages to disk' box
is unticked.

Internet Options

[ Help

| General | Security || Privacy | Content | Connections | Programs ‘ Advanced

Delete Browsing History...
Settings

Pop-up Blocker » B searty =
Phishing Filter b ] Allow active content from CDs to run on My Computer®
Manage Add-ons » [ Allow active content to run in files on My Computer®

[ Allow software to run or install even if the signature is invi

Check for publisher's certificate revocation

[ Check for server certificate revocation®

Chedk for signatures on downloaded programs
Windows Update Do not save encrypted pages to disk

["] Empty Temporary Internet Files folder when browser is de
Windows Messenger Enable Integrated Windows Authentication®
Diagnose Connection Problems... Enable native XMLHTTP support

[ Phishing Filter =

(O Turn off automatic website checking ! o
¢ i >

*Takes effect after you restart Internet Explorer

With this change made you now need to restart your browser for the changes to take effect. You
should now have no problems when you try to export your payslip.

10



6.3 Printing Payslips from within different Internet Browsers

Alternatively you can print directly from your browser window. However the full webpage details will
also show up when printing from within your browser.

Background Image Missing

When printing your payslip from within your internet browser you may find that only the text appears

but the background image is missing. This is due to a print setting within your internet browser that
needs to be turned on.

Internet Options

General | Security || Privacy | Content | Connections | Programs Advanced
Settings

Flay sounds in webpages -
] show image download placeholders
Show pictures
Smart image dithering
: Rrnting
background colors and images
J~Search from the Address bar
() Do not search from the Address bar
(%) Just display the results in the main window
% Security
[] allow active content from COs to run on My Computer™

Microsoft Internet Explorer 7

Click Tools -> Internet Options -> Advanced. Scroll down to Printing and tick the option to print
background colours and images box.

If using Microsoft Internet Explorer 8 you can change this option from the File -> Page Setup
Menu option.

Google Chrome
Go to the settings menu

Select Print->Options and tick the ‘Background colours and images’ box.

Margins Default v

Options Headers and footers

«| Background colours and images

Print using system dizlogue... (Ctri+Shift+P)

11



Mozilla FireFox

Before selecting the print option, go to File -> Page Setup and tick ‘Print Background (colours &
images)’ box.
Tick box as shown below under 'Options’

‘ Format

| scale: | | % [ shrink to fit Page Width

Options
‘ rint Background (colors & images)

Then Select File->Print->0k

7. Difficulties Registering / Logging in/ Viewing Payslip

7.1 Forgotten Password

If you are unable to remember your password, please click the forgotten password link on the login
form.

Login

Perzonnel Mo:
Password:

Email Address:

/ Forgotten your Password? Log In

Online Payslips Password Recovery

Click here

Password reset Tips & Support
Please enter your Personnel number to reset your If you have any any issues resetting your password
password please contact epayslips@hse.ie and include your

Personnel Number: * Name

* Personal number

* Contact number

* And a short discription of the problem you are

Next having.

Enter your personnel number in the field and click next.



When you click next an email will be sent to you with a temporary password which will allow you to
log into the site again.

Password reset

A temporary password has been emailed to you.

turn to Login Screen

Click ‘Return to Login Screen’

7.2 User Inactivity

If you are logged in but not actively using the online payslips solution, it will lock after 8 minutes of
inactivity in which case you will need to go through to login steps again. Always remember to follow

the HSE data security rules which can be viewed by clicking the link below.
http://www.hse.ie/eng/services/Publications/pp/ict/Information Security Policy.pdf

Your session has expired

As a security precaution, you have been automatically logged out.
This happens when your account is idle for a period of time.

To continue accessing your account

Click here to login again

7.3 Payslip Not Displaying
Newer versions of Internet Explorer can experience problems displaying content on certain websites.
You may experience an issue with these newer versions when trying to view your epayslip online.

However this issue can be simply resolved by adding the HSE website to a compatibility mode list
within the browser.

If you have Internet Explorer 8, 9 or 10 then click the following button if available to put the HSE
website into compatibility mode.

@L_ ,)‘ @ http://www.hse.ie/eng/staff/onlinepayslip: O

File Edit View Favorites Tools Help | Compatibility View: websites designed for older browsers will often look better,
and problems such as out-of-place menus, images, or text will be corrected.

= HSE.ie - Welcome to the O...

Search
The Page will reload itself and you should now be able to view your payslip

However if the icon is not available you will then need to do the following;

1. In Internet Explorer, click on Tools on the menu bar. If you do not see the menu bar you may
need to press the Alt button on your keyboard. The Alt button can be found to the left of the
space bar. Unless you have the menu bar enabled, this will be a gear icon

13


http://www.hse.ie/eng/services/Publications/pp/ict/Information_Security_Policy.pdf

Print »
File >
Zoom (100%) »
. . . . Safety »
Click Compatibility View Settings.
Add site to Start menu
View downloads Ctrl+)

Manage add-ons

I F12 Developer Tools

Go to pinned

Compatibility View settings

2. Under Add this website, enter http://www.hse.ie and click Add and then Close.

(Comproiyvevsers T =

Change Compatibiity View Settings

3. Refresh the webpage by pressing the F5 key (usually above the number 6 key) on your
keyboard and you should now be able to view your payslip.

14



http://www.hse.ie/

8. Payroll Related Queries - Contacts

Email: tusla.payroll@hse.ie
Tel: 061 483298


mailto:child@familypayroll@ngahr.com

